Got one of our Nutanix demo boxes back from the field a while ago and set it up again in our demo lab.
Our lab network is VLAN segmented and the last time I did similar exercise, I had to set Acropolis Hypervisor (AHV) to send tagged frames also for management (CVM/Hypevisor) traffic. Instructions for this can be found from Virtual LANs for your Acropolis Hypervisor Virtual Machines. This includes modifying bridge “br0” on all AHV hosts , one AHV host at time. And setting each Controller Virtual Machine (CVM) to use VLAN tagging.
However in the post above Nutanix recommends CVM and Hypervisor traffic to use “untagged” (or native VLAN).
I was wondering whether you could use native VLAN setting for management traffic by modifying switch configuration and skip making changes to AHV hosts and CVMs. It would be much easier especially if you have many AHV hosts. Just log in to your switch and make changes in one place rather than logging into each and every AHV host / CVM separately.
We have a pair of Brocade VDX6740 10GbE switches in our lab (Thanks Brocade!!). There is a deployment guide for Nutanix + Brocade combination.
In the deployment guide they expect native VLAN to be VLAN 1. Each Nutanix appliance port set to “with no tagging of frames arriving on native vlan 1” with configuration line:
“no switchport trunk tag native-vlan”
Example Brocade switch configuration for one of the Nutanix Appliance ports:
interface TenGigabitEthernet 1/0/3
description Connected-to-Nutanix-Node1
fabric isl enable
fabric trunk enable
switchport
switchport mode trunk
switchport trunk allowed vlan all
no switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown
Surely you can change the native VLAN for the switch, but what if that VLAN is already used by some other service and you cannot change the default native VLAN?
No worry, you can set different native VLAN by port basis.
In our use case Nutanix management should use VLAN 301.
- First create VLAN to be used as native VLAN per port
- conf t
- interface vlan 301
- then set native VLAN to each of the Nutanix appliance ports on switch 1
- (multiple ports at the same time, ports 1/0/1,1/0/2 and 1/0/3)
- interface TenGigabitEthernet 1/0/1-3
- switchport trunk native-vlan 301
- And repeat for the other switch Nutanix appliance ports
- interface TenGigabitEthernet 2/0/1-3
- switchport trunk native-vlan 301
No need to mess around with AHV host bridge settings. Now all untagged traffic arriving on Nutanix appliance ports is tagged to VLAN 301.